Fix: Bildsuche im Admin-Bereich bleibt leer

Vorhaben

In der derzeitigen Version von OpenCart hat sich ein kleiner Fehler eingeschlichen. So bleibt die Suche nach Bildern im Bild-Upload Fenster des Administrations-Bereichs leer, wenn man einen Suchbegriff eingibt. Dies lässt sich allerdings mit einer sehr kleinen BugFix-Erweiterung beheben.

1. Code

<modification>
    <name>Image Manager Search Fix</name>
    <version>1.1</version>
    <code>image-manager-search-fix</code>
    <author>cyclops</author>

    <file path="admin/controller/common/filemanager.php">
                <operation error="skip">
                        <search><![CDATA[
            if (substr(str_replace('\\', '/', realpath($directory . '/' . $filter_name)), 0, strlen(DIR_IMAGE . 'catalog')) == DIR_IMAGE . 'catalog') {
            ]]></search>
                        <add position="replace" offset="14"><![CDATA[
            // Get directories
            $directories = glob($directory . '/' . $filter_name . '*', GLOB_ONLYDIR);

            if (!$directories) {
                $directories = array();
            }

            // Get files
            $files = glob($directory . '/' . $filter_name . '*.{jpg,jpeg,png,gif,JPG,JPEG,PNG,GIF}', GLOB_BRACE);

            if (!$files) {
                $files = array();
            }
            ]]></add>
                </operation>
    </file>
</modification>

2. Modifikation einbinden

Kopiert den o.g. Code in einen Texteditor und passt die Links nach euren Wünschen an.
Speichert alles dann als "fix_fuer_bildsuche.ocmod.xml". Nun ladet ihr das Modul noch über das Modifikations-System von OpenCart hoch.

3. Quelle:

User Cyclops auf forum.opencart.com

Eine Antwort hinterlassen

Deine eMail Adresse wird nicht veröffentlicht. Benötigte Felder sind markiert *